Stuck in South Edge, cannot zone into the previous area (near the village).


Mosha Sou
 Share

Recommended Posts

I tried logging out and back in, closing the app completely then re-opening it.

I ran my character away from the exit and then back to it, and I tried killing enemies and then waiting for battle to de-commence, however nothing allowed me to leave, so left with no other option I committed suicide to get out of south edge.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share